思科实验 三层交换机的配置和使用

思科实验三层交换机的配置和使用
实验总览
  • 实验目的:了解三层交换机的端口使用及应用方法
  • 前提 : 具有和掌握配置路由器和了解交换机的基础,以及熟练应用下一跳的

三层交换机百度百科 : https://baike.baidu.com/item/%E4%B8%89%E5%B1%82%E4%BA%A4%E6%8D%A2%E6%9C%BA/816331

三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。

第一步 配置和划分PC的 IP 以及vlan

网段以及vlan划分

这里配置的网段和vlan你可以按照你的想法来

这里 第一台pc设置192.168.1.2网段,【注意】需要配置网关:192.168.1.1。

其余pc与上相同 更换网段即可 不再赘述。

第二步 配置 交换机

进入左侧三层交换机 1 ,【注意】这里用的不是二层交换机,是三层 3560 24PS型号

//创建 vlan
Switch>
Switch>en
Switch#configure 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2          //创建 vlan 2
Switch(config-vlan)#exit       //退出操作 下面与上同 不在赘述
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#vlan 4
Switch(config-vlan)#exit
Switch(config)#

//将端口绑定到 vlan 中 
Switch(config)#
Switch(config)#interface f0/1
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 2
Switch(config-if)#exit
Switch(config)#interface f0/2
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 3
Switch(config-if)#exit
Switch(config)#interface f0/3
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 4
Switch(config-if)#exit
Switch(config)#

//配置 vlan 的 IP 地址
Switch(config)#interface vlan 2          //进入vlan 2  
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan2, changed state to up
     //配置vlan 2 的IP 地址 为PC0 的网关 子网掩码
Switch(config-if)#ip address 192.168.1.1 255.255.255.0   
Switch(config-if)#exit         //退出操作 下面操作同上 不赘述
Switch(config)#interface vlan 3
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 4
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan4, changed state to up
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing     //【重点】 输入 IP routing 打开三层交换机的路由功能
Switch(config)#


//到这里 配置完成一半
【注意】这台交换机 是一个三层交换机 所以连接路由的那一个口不是二层交换机的口而是同路由器的gigabitEthernet 口 所以需要配置 端口ip ,下一步就是打开端口 给它配置端口ip

//进入三层交换机 1 的全局配置模式
Switch(config)#interface gigabitEthernet 0/1   //进入端口git 0/1 【注意】这里没有0/0
Switch(config-if)#no switchport 
Switch(config-if)#ip address 192.168.7.1 255.255.255.0   //添加端口 ip 这里选用7.0网段
Switch(config-if)#no shutdown                            //开启该端口
Switch(config-if)#exit                                   //退出操作
Switch(config)#
【Tips】no switchport 的意思是 把二层接口改为三层接口,也就是说相当于一个路由器上的接口

OK , 到这里 左侧的设备配置的差不多了 接下来看看右侧的设备

右侧添加一个新的 3560 三层交换机

//创建 vlan
Switch>
Switch>en
Switch#configure 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2          //创建 vlan 2
Switch(config-vlan)#exit       //退出操作 下面与上同 不在赘述
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#vlan 4
Switch(config-vlan)#exit
Switch(config)#


//将端口绑定到 vlan 中 
Switch(config)#
Switch(config)#interface f0/1
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 2
Switch(config-if)#exit
Switch(config)#interface f0/2
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 3
Switch(config-if)#exit
Switch(config)#interface f0/3
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 4
Switch(config-if)#exit
Switch(config)#

//配置 vlan 的 IP 地址
Switch(config)#interface vlan 2          //进入vlan 2  
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan2, changed state to up
     //配置vlan 2 的IP 地址 为PC3 的网关 子网掩码
Switch(config-if)#ip address 192.168.4.1 255.255.255.0   
Switch(config-if)#exit                                //退出操作 下面操作同上 不赘述
Switch(config)#interface vlan 3
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Switch(config-if)#ip address 192.168.5.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 4
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan4, changed state to up
Switch(config-if)#ip address 192.168.6.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing     //【重点】 输入 IP routing 打开三层交换机的路由功能
Switch(config)#

//进入三层交换机 2 的全局配置模式
Switch(config)#interface gigabitEthernet 0/1   //进入端口git 0/1 【注意】这里没有0/0
Switch(config-if)#no switchport  //开启三层 路由器的接口
Switch(config-if)#ip address 192.168.8.2 255.255.255.0   //添加端口 ip 这里选用8.2ip
Switch(config-if)#no shutdown                            //开启该端口
Switch(config-if)#exit                                   //退出操作
Switch(config)#

//到这里 ip 已经全部配置完成了

这个时候端口还是红色的,别急,咱们配置路由器。

第三步 配置路由器

进入 到路由器 R1 中

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>en                  //进入特权模式
Router#configure           //进入全局配置模式
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
//进入端口 0/0 也就是和左侧三层交换机连接的端口
Router(config)#interface gigabitEthernet 0/0 
//添加 IP 地址 因为左侧的三层交换机 0/1 口配置的是 7.1 所以这里也要配置 7.0网段的ip   
Router(config-if)#ip address 192.168.7.2 255.255.255.0
Router(config-if)#no shutdown        //打开端口
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit               //退出操作
//进入端口 0/0 也就是和右侧三层交换机连接的端口
Router(config)#interface gigabitEthernet 0/1
//添加 IP 地址 因为左侧的三层交换机 0/1 口配置的是 8.2 所以这里也要配置 8.0网段的ip 
Router(config-if)#ip address 192.168.8.1 255.255.255.0
Router(config-if)#no shutdown   //打开端口
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Router(config-if)#exit  退出操作
Router(config)#

现在,中间路由器的端口打开了,但是并不代表已经成功了。

最后 一步 配置 所有设备的下一跳 ※

1-1 进入左侧的交换机

Switch#
Switch#configure 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#ip route 192.168.4.2 255.255.255.255 192.168.7.2
Switch(config)#ip route 192.168.5.2 255.255.255.255 192.168.7.2
Switch(config)#ip route 192.168.6.2 255.255.255.255 192.168.7.2
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
//这是左侧的三层交换机的下一跳 

1-2 进入右侧的交换机

Switch#conf
Switch#configure 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#
Switch(config)#ip route 192.168.1.2 255.255.255.255 192.168.8.1
Switch(config)#ip route 192.168.2.2 255.255.255.255 192.168.8.1
Switch(config)#ip route 192.168.3.2 255.255.255.255 192.168.8.1
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
//这是右侧的三层交换机的下一跳

重点 ※ 路由的下一跳 请注意

1-3 进入中间的路由器

Router#conf
Router#configure 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip route 192.168.1.2 255.255.255.255 192.168.7.1
Router(config)#ip route 192.168.2.2 255.255.255.255 192.168.7.1
Router(config)#ip route 192.168.3.2 255.255.255.255 192.168.7.1
Router(config)#
Router(config)#ip route 192.168.4.2 255.255.255.255 192.168.8.2
Router(config)#ip route 192.168.5.2 255.255.255.255 192.168.8.2
Router(config)#ip route 192.168.6.2 255.255.255.255 192.168.8.2
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#

ok,实验结束 下面我们测试一下

成功ping

实验结束,感谢你的阅读观看。

Views: 125

默认图片
JiHua

一个专注于前端和NodeJs的网站开发者

文章: 48

留下评论